Do I need to update the firmware on my pedal to use MultiSwitch Plus? - Strymon

Do I need to update the firmware on my pedal to use MultiSwitch Plus?

At the time of release (March 2019), all Strymon pedals that can accept a MiniSwitch via the EXP jack except BigSky, Mobius, and TimeLine are compatible with MultiSwitch Plus.  For these pedals, a firmware update is required for compatibility with MultiSwitch Plus.  Please visit strymon.net/update for instructions on how to update BigSky, Mobius and TimeLine.